Withdrawing renBTC via Metamask

After re-reading the manual and instructions for operating nodes, I am still uncertain about how to withdraw renBTC to metamask wallet. After this past epoch ended, ETH was spent and pending funds were moved to withdrawable (half being left in pending for the following epoch), but I do not see an arrow next to to the withdraw tab as the manual states must be clicked on to initiate a transfer to my wallet.

I am using Ledger with metamask if this has any known issues. If someone would direct me to anything I am missing, I want to iron out the process early and not assume I have done all that is necessary.

Much appreciated!

You connect to the Darknode Control Center with the same address you used to setup your Darknode.

Next you choose the darknode you want to withdraw from (or if you have multiple, you can choose the “4 squares” button in the top left corner to withdraw from all your darknodes) and click the small arrow near the asset you want to withdraw:

This will promt metamask to confirm the withdrawal tx.

That’s it.

Ok that’s great, thanks for the screenshot! I do not have these arrows displaying however, so I guess since last month was my first completed epoch maybe on the next one I will be able to withdraw?

See my screenshot as well for reference.

That seems like a bug. You can fill out a bug report form (blue icon the lower right corner). Also you can try resizing your window and opening the DN CC in another browser. :man_shrugging:

You need to make sure the metamask is connecting to the ledger and not the address it created when you signed up. Do you see the red “deregister” button next to your “Registered” status? If not, then yeah it appears you are really not signed in to your node. If you have any other defi apps you use with metamask and ledger see if they are connecting to your node address via the ledger or to the other metamask address.


That was in fact the issue… everytime I was connecting to the node it was connected to metamask but not my Ledger device even though I was signed in with the correct address. Not sure why it worked this time after reading your message here but regardless, I can now withdraw. Great insight.

Much appreciated!

Thank you… I did submit one. Someone else (Shiny) had an idea which solved the glitch… it was an issue with metamask connection.