Troubleshooting - Minting RenBTC on polygon, ledger

I sent btc to the address, which was confirmed, but I’ve been unable to mint the RenBTC. I’m using Metamask and a Ledger wallet, are there any known issues or instructions? I filled out the ticket response form around 8 hours ago but have not heard back.

I added RenBTC as a token on Metamask polygon. I have enough MATIC in the account for the transaction fee. On my Ledger, in both the ethereum and polygon apps, I have blind signing turned on. I tried rebooting my computer. On, Status is “Ready for minting” with a “Connect wallet” button, but when I press that, it just shows “Submitting” indefinitely. Metamask shows 4 prior failed transactions and one Mint transaction “Pending” with -0 MATIC on the right side. I tried to submit the transaction both with and without Ledger Live open. Metamask shows Polygon mainnet. Am using Firefox and linux.

Solved it, in case anyone has the same issue, I found that by switching network in Metamask (eg, polygon to ethereum and switching back), it displayed an error message, and updated the status on the ren explorer page.

Found others with the same issue:

The first solution of uninstalling and reinstalling metamask worked for me.